
Example name  Second-hand smoke and lung-cancer 
Effect size  Risk ratio 
Analysis type  Publication bias 
Level    Advanced 
 
Synopsis 
 
Studies compared the risk of lung cancer in non-smokers whose spouse was (or was not) a smoker.  The 
pooled effect showed an increase risk of lung-cancer for the second group, but there was concern that 
the estimate could have been affected by publication bias. 
 
We use this example to show 
 

• The distinction between a small-study effect and publication bias 
• How to use the Fail-Safe N (and why not to) 
• How to use the Egger test 
• How to use Trim and Fill 
• How to use a cumulative analysis to assess the potential impact of bias 

 

To open a CMA file > Download and Save file | Start CMA | Open file from within CMA 

Download CMA file for computers that use a period to indicate decimals  
Download CMA file for computers that use a comma to indicate decimals  
 
Download this PDF 
Download data in Excel 
Download trial of CMA  
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Start the program 

• Select the option [Start a blank spreadsheet] 
• Click [Ok] 
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 Click Insert > Column for > Study names 

 

The screen should look like this 

 

Click Insert > Column for > Effect size data 
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The program displays this wizard   
   
Select [Show all 100 formats] 
Click [Next] 
 

 

 
   
Select [Comparison of two groups…] 
Click [Next] 
 

 

 
   
Drill down to 
 
Dichotomous (number of events) 
Computed effect sizes 
Risk ratio and confidence limits 
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The screen should look like this 
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There are three options at this point 

• Enter the data directly into CMA  
• – or – Open the CMA data file “Smoking.cma” 
• – or – Copy the data from Excel “Smoking..xls” 

Rather than enter the data directly into CMA we will copy the data from Excel 

• Switch to Excel and open the file  
• Highlight the rows and columns as shown, and press CTRL-C to copy to clipboard 
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Switch back to CMA 

• Click in Cell Study name – 1 
• Press [CTRL-V] to paste the data into CMA 

  

  

Click here 
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• Click in the first row to select it 
• Click Edit > Delete row and confirm  

 

 

The screen should look like this 

 

  

Click here 
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At this point we should save the file 

• Click File > Save As … 

 

Note that the file name is now in the header.   

• [Save] will over-write the prior version of this file without warning 
• [Save As…] will allow you to save the file with a new name 
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For reasons that will become clear momentarily, it would be useful to sort the studies with those with 
the smallest standard error at the top and those with larger standard errors at the bottom. 

• Right-click on the “Std Err” column 
• Click Sort A-Z 
• Save the file 

 

To run the analysis, click [Run analysis] 
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This is the basic analysis screen 

Initially, the program displays the fixed-effect analysis.  This is indicated by the tab at the bottom and 
the label in the plot. 
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Click [Both models] 

The program displays results for both the fixed-effect and the random-effects analysis. 

 

 

 

The random-effects model is a better fit for the way the studies were sampled, and therefore that is the 
model we will use in the analysis. 
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• Click Random on the tab at the bottom 

The plot now displays the random-effects analysis alone. 

 

 

 

 The summary effect is 1.238 with a CI of 1.129 to 1.356 
 The summary effect has a Z-value 4.562 and a p-value of < 0.001.  Thus we can reject the null 

hypotheses that the true risk ratio is 1.0. 
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Click [Next table]  

 

 

 

 

The statistics at the left duplicate those we saw on the prior screen. 

 The summary effect is 1.238 with a CI of 1.129 to 1.356. 
 The summary effect has a Z-value 4.562 and a p-value of < 0.001.  Thus we can reject the null 

hypotheses that the true risk ratio is 1.0. 
 The Q-value is 47.498 with df=36 and p=0.095.  Q reflects the distance of each study from the 

mean effect (weighted, squared, and summed over all studies).  Q is always computed using FE 
weights (which is the reason it is displayed on the “Fixed” row, but applies to both FE and RE 
analyses. 

 If all studies actually shared the same true effect size, the expected value of Q would be equal to 
df (which is 36).  Here, Q is greater than 36, which tells us that there is some excess dispersion in 
effects, and p is 0.095, which tells us that this amount of excess dispersion is statistically 
significant using the criterion of 0.10 (which is the suggested criterion for this test). 

 T2 is the estimate of the between-study variance in true effects.  This estimate is 0.017. T is the 
estimate of the between-study standard deviation in true effects.  This estimate is 0.129.  Note 
that these values are in log units.  

 The variance in effect sizes includes both sampling error and variance in the true effect size from 
study to study.  The I2 value is 24.207, which tell is that about one-fourth of the variance in 
observed effects reflects differences in true effect sizes. 

 

  

Click here 
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While it’s clear that these studies show that being married to a smoker is associated with an increased 
risk of lung-cancer, there was concern that the studies in the analysis were not representative of all 
studies that had been conducted.  

Consider the following scenario:  100 researchers run studies similar to the ones in this analysis.  Some 
find an increased risk for second-hand smoke, some find no risk, and some find that second-hand smoke 
is associated with a decreased risk of lung-cancer. (Note that we’re talking about the direction of the 
effect, not necessarily a statistically significant effect). 

The researchers who find an increased risk proceed to publish, those who find no relationship are less 
likely to publish, and those who find a protective effect for smoking are even less likely to publish.  What 
happens is that the papers that are published tend to over-estimate the true effect size.  These, of 
course, are the papers that are more likely to find their way into the meta-analysis. 

Is it plausible that the true relationship between second-hand smoke and lung-cancer across all the 
studies that had been performed is nil, and the effect that we see in these studies is entirely an artifact 
of publication bias? 

A number of procedures have been developed to test for publication bias and/or assess its potential 
impact on the results.  Here, we outline how to perform these analyses, without fully discussing their 
meaning.  We should note, however, that most of these analyses are based on the assumption that if 
small studies show a larger effect than large studies, this may be evidence of publication bias. In truth, 
this may be evidence of publication bias but may also be a small study effect, such that the effect is 
actually larger in smaller studies for legitimate reasons. 

  

© www.Meta-Analysis.com                          Smoking                                                            —  17 — 

   

http://www.meta-analysis.com/


To run the analyses 

Click Analyses > Publication bias  
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© www.Meta-Analysis.com                          Smoking                                                            —  22 — 

   

http://www.meta-analysis.com/


The program generates the following report 
 
Report starts here 
 
Introduction to publication bias 
 
The basic issue of publication bias is that not all completed studies are published, and the selection 
process is not random (hence the 'bias'). Rather, studies that report relatively large treatment effects 
are more likely to be submitted and/or accepted for publication than studies which report more modest 
treatment effects. 
 
Since the treatment effect estimated from a biased collection of studies would tend to overestimate the 
true treatment effect, it is important to assess the likley extent of the bias, and its potential impact on 
the conclusions. This module includes several tools which may be used for this purpose. 
 
Funnel plot 
 
The funnel plot is a plot of a measure of study size (usually standard error or precision) on the vertical 
axis as a function of effect size on the horizontal axis.  
 
Large studies appear toward the top of the graph, and tend to cluster near the mean effect size.  Smaller 
studies appear toward the bottom of the graph, and (since there is more sampling variation in effect size 
estimates in the smaller studies) will be dispersed across a range of values.   
 
In the absence of publication bias we would expect the studies to be distributed symmetrically about 
the combined effect size.  By contrast, in the presence of bias, we would expect that the bottom of the 
plot would show a higher concentration of studies on one side of the mean than the other.  This would 
reflect the fact that smaller studies (which appear toward the bottom) are more likely to be published if 
they have larger than average effects, which makes them more likely to meet the criterion for statistical 
significance. 
 
Various statistical procedures can be accessed from the View menu to quantify or augment this display.  
 
The classic fail-Safe N and the Orwin fail-safe N ask if we need to be concerned that the entire observed 
effect may be an artifact of bias.  Rank correlation and regression procedures can test for the presence 
of bias.  Trim and Fill offers a more nuanced perspective, and asks how the effect size would shift if the 
apparent bias were to be removed.  
 
Classic fail-safe N 
 
One concern of publication bias is that some non-significant studies are missing from our analysis and 
that these studies, if included, would nullify the observed effect.   
 
Robert Rosenthal suggested that rather than simply speculate about the impact of the missing studies, 
we compute the number of studies that would be required to nullify the effect. If this number is 
relatively small then there is indeed cause for concern. However, if this number is large, we can be 
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confident that the treatment effect, while possibly inflated by the exclusion of some studies, is 
nevertheless not nil. 
 
He suggested that this analysis be called a 'File-drawer' analysis, file drawers being the presumed 
location of the missing studies.  Harris Cooper proposed the term 'Fail-Safe N', a reference to the 
number of missing studies that would nullify the effect.   
 
This approach is limited in two important ways.  First, it assumes that the effect in the hidden studies is 
nil, rather than considering the possibility that some of the studies could have shown an effect in the 
reverse direction.  Therefore, the number of studies required to nullify the effect may be smaller than 
the Fail-Safe N.  
 
Second, and more fundamentally, this approach focuses on statistical significance rather than clinical or 
substantive significance.  That is, it may allow us to assert that the treatment effect is not nil, but does 
not address the question of whether or not it remains clinically important after the missing studies have 
been included. 
 
Note also that the fail-safe N algorithm computes a p-value for each study and then combines these p-
values.  By contrast, the generally accepted approach today (and the one used by this program) is to 
compute an effect size for each study, combine the effect sizes, and then compute the p-value for the 
combined effect. The two approaches do not generally yield identical results. 
 
This meta analysis incorporates data from 37 studies, which yield a z-value of 5.63630 and 
corresponding 2-tailed p-value of 0.00000.   
 
The fail-safe N is 269.  This means that we would need to locate and include 269 'null' studies in order 
for the combined 2-tailed p-value to exceed 0.050.   
 
Put another way, there would be need to be 7.3 missing studies for every observed study for the effect 
to be nullified.  
 
Orwin fail-safe N 
 
Like the classic fail-safe N, the Orwin fail-safe N addresses the possibility that studies are missing from 
the analysis and that these studies, if included in the analysis, would shift the effect size toward the null. 
 
Orwin's fail-safe N differs from the classic fail-safe N in two ways.  
 
First, the mean risk ratio in the new (missing) studies can be a value other than the nil value (currently, it 
is set to 1). 
 
Second, the criterion value is an effect size rather than a p-value.  That is, the Orwin fail-safe N is the 
number of (missing) studies that, when added to the analysis, will bring the combined risk ratio below a 
specified threshold (currently, 1.05). 
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The Orwin fail-safe N is 104.  This means that we would need to locate 104 studies with mean risk ratio 
of 1 to bring the combined risk ratio under 1.05 
 
Begg and Mazumdar Rank Correlation Test 
 
The classic case of publication bias is the case depicted by the funnel plot.  Large studies tend to be 
included in the analysis regardless of their treatment effect whereas small studies are more likely to be 
included when they show a relatively large treatment effect.  Under these circumstances there will be 
an inverse correlation between study size and effect size.   
 
Begg and Mazumdar suggested that this correlation can serve as a test for publication bias.  Concretely, 
they suggest that we compute the rank order correlation (Kendall's tau b) between the treatment effect 
and the standard error (which is driven primarily by sample size). 
 
This approach is limited in some important ways.  A significant correlation suggests that bias exists but 
does not directly address the implications of this bias.  Conversely, a non-significant correlation may be 
due to low statistical power, and cannot be taken as evidence that bias is absent.   
 
In this case Kendall's tau b (corrected for ties, if any) is 0.14264, with a 1-tailed p-value (recommended) 
of 0.10703 or a 2-tailed p-value of 0.21405 (based on continuity-corrected normal approximation).   
 
Egger's Test of the Intercept 
 
Egger suggests that we assess this same bias by using precision (the inverse of the standard error) to 
predict the standardized effect (effect size divided by the standard error).  In this equation, the size of 
the treatment effect is captured by the slope of the regression line (B1) while bias is captured by the 
intercept (B0).   
 
This approach may offer a number of advantages over the rank correlation approach.  Under some 
circumstances this may be a more powerful test.  Additionally, this approach can be extended to include 
more than one predictor variable, which means that we can simultaneously assess the impact of several 
factors, including sample size, on the treatment effect. 
 
In this case the intercept (B0) is  0.89225,  95% confidence interval (0.12747, 1.65703), with t=2.36848, 
df=35. The 1-tailed p-value (recommended) is 0.01176,  and the 2-tailed p-value is 0.02351. 
 
Duval and Tweedie's Trim and Fill 
 
If the meta analysis had captured all the relevant studies we would expect the funnel plot to be 
symmetric. That is, we would expect studies to be dispersed equally on either side of the overall effect.  
Therefore, if the funnel plot is actually asymmetric, with a relatively high number of small studies 
(representing a large effect size) falling toward the right of the mean effect and relatively few falling 
toward the left, we are concerned that these left-hand studies may actually exist, and are missing from 
the analysis.  
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Duval and Tweedie developed a method that allows us to impute these studies. That is, we determine 
where the missing studies are likely to fall, add them to the analysis, and then recompute the combined 
effect.   
 
The method is known as 'Trim and Fill' as the method initially trims the asymmetric studies from the 
right-hand side to locate the unbiased effect (in an iterative procedure), and then fills the plot by re-
inserting the trimmed studies on the right as well as their imputed counterparts to the left the mean 
effect.   
 
The program is looking for missing studies based on a fixed effect model, and is looking for missing 
studies only to the left side of the mean effect (these parameters are set by the user). Using these 
parameters the method suggests that 7 studies are missing.   
 
Under the fixed effect model the point estimate and 95% confidence interval for the combined studies is 
1.20406 (1.11988, 1.29457).  Using Trim and Fill the imputed point estimate is 1.16893 (1.08901, 
1.25471).   
 
Under the random effects model the point estimate and 95% confidence interval for the combined 
studies is 1.23770 (1.12934, 1.35645).  Using Trim and Fill the imputed point estimate is 1.18862 
(1.08023, 1.30789).   
 
To plot the imputed studies click 'Funnel plot' and then select 'Plot observed and imputed' on the 
toolbar. 
 
An important caveat 
 
Sterne and Egger note that while the plot and these procedures may detect a relationship between 
sample size and effect size, they cannot assign a causal mechanism to it.  
 
That is, the effect size MAY be larger in small studies because we retrieved a biased sample of the 
smaller studies.  However, it is also possible that the effect size really IS larger in smaller studies - 
perhaps because the smaller studies used different populations or different protocols than the larger 
ones. 
 
Sterne and Egger use the term 'small study effect' to capture these and other potential confounds.  
 

Report ends here 
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Finally, we can run a cumulative analysis, sorted by standard error 
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